Browse Source

Update JS dependencies (#15290)

- Update all JS dependencies to latest version, no functional changes.
- Remove unused direct dependencies core-js and terser-webpack-plugin.

Co-authored-by: techknowlogick <techknowlogick@gitea.io>
Co-authored-by: 6543 <6543@obermui.de>
pull/14914/merge
silverwind 2 weeks ago
committed by GitHub
parent
commit
1ba8b95eb4
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 572 additions and 1104 deletions
  1. +562
    -1092
      package-lock.json
  2. +10
    -12
      package.json

+ 562
- 1092
package-lock.json
File diff suppressed because it is too large
View File


+ 10
- 12
package.json View File

@ -10,10 +10,9 @@
"add-asset-webpack-plugin": "2.0.1",
"clipboard": "2.0.8",
"codemirror": "5.60.0",
"core-js": "3.9.1",
"css-loader": "5.1.3",
"css-loader": "5.2.0",
"css-minimizer-webpack-plugin": "1.3.0",
"dropzone": "5.8.1",
"dropzone": "5.9.2",
"easymde": "2.14.0",
"esbuild-loader": "2.11.0",
"escape-goat": "3.0.0",
@ -25,36 +24,35 @@
"less-loader": "8.0.0",
"license-checker-webpack-plugin": "0.2.1",
"mermaid": "8.9.2",
"mini-css-extract-plugin": "1.3.9",
"mini-css-extract-plugin": "1.4.0",
"monaco-editor": "0.23.0",
"monaco-editor-webpack-plugin": "3.0.1",
"postcss": "8.2.8",
"postcss": "8.2.9",
"pretty-ms": "7.0.1",
"sortablejs": "1.13.0",
"swagger-ui-dist": "3.45.1",
"terser-webpack-plugin": "5.1.1",
"swagger-ui-dist": "3.46.0",
"tributejs": "5.1.3",
"vue": "2.6.12",
"vue-bar-graph": "1.2.0",
"vue-calendar-heatmap": "0.8.4",
"vue-loader": "15.9.6",
"vue-template-compiler": "2.6.12",
"webpack": "5.28.0",
"webpack-cli": "4.5.0",
"webpack": "5.30.0",
"webpack-cli": "4.6.0",
"workbox-routing": "6.1.2",
"workbox-strategies": "6.1.2",
"worker-loader": "3.0.8",
"wrap-ansi": "7.0.0"
},
"devDependencies": {
"eslint": "7.22.0",
"eslint": "7.23.0",
"eslint-plugin-html": "6.1.2",
"eslint-plugin-import": "2.22.1",
"eslint-plugin-unicorn": "29.0.0",
"eslint-plugin-vue": "7.7.0",
"eslint-plugin-vue": "7.8.0",
"stylelint": "13.12.0",
"stylelint-config-standard": "21.0.0",
"svgo": "2.2.2",
"svgo": "2.3.0",
"updates": "11.4.3"
},
"browserslist": [


Loading…
Cancel
Save