Browse Source

Use Golang 1.18 for Gitea 1.17 release (#19918)

Use Golang 1.18 (as minimal requirement) for Gitea 1.17 release, make sure the Golang version is still actively supported during Gitea 1.17 lifecycle.

Co-authored-by: zeripath <art27@cantab.net>
Co-authored-by: Lunny Xiao <xiaolunwen@gmail.com>
Co-authored-by: 6543 <6543@obermui.de>
pull/18076/merge
wxiaoguang 3 weeks ago committed by GitHub
parent
commit
5f618248a9
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
  1. 2
      .drone.yml
  2. 2
      README.md
  3. 2
      docs/config.yaml
  4. 4
      docs/content/doc/advanced/config-cheat-sheet.en-us.md
  5. 2
      go.mod

2
.drone.yml

@ -109,7 +109,7 @@ steps:
depends_on: [test-frontend]
- name: build-backend-no-gcc
image: golang:1.17 # this step is kept as the lowest version of golang that we support
image: golang:1.18 # this step is kept as the lowest version of golang that we support
pull: always
environment:
GO111MODULE: on

2
README.md

@ -73,7 +73,7 @@ or if SQLite support is required:
The `build` target is split into two sub-targets:
- `make backend` which requires [Go 1.17](https://go.dev/dl/) or greater.
- `make backend` which requires [Go Stable](https://go.dev/dl/), required version is defined in [go.mod](/go.mod).
- `make frontend` which requires [Node.js LTS](https://nodejs.org/en/download/) or greater and Internet connectivity to download npm dependencies.
When building from the official source tarballs which include pre-built frontend files, the `frontend` target will not be triggered, making it possible to build without Node.js and Internet connectivity.

2
docs/config.yaml

@ -19,7 +19,7 @@ params:
author: The Gitea Authors
website: https://docs.gitea.io
version: 1.16.8
minGoVersion: 1.17
minGoVersion: 1.18
goVersion: 1.18
minNodeVersion: 14

4
docs/content/doc/advanced/config-cheat-sheet.en-us.md

@ -315,8 +315,8 @@ The following configuration set `Content-Type: application/vnd.android.package-a
- `SSL_MAX_VERSION`: **\<empty\>**: Set the maximum version of ssl support.
- `SSL_CURVE_PREFERENCES`: **X25519,P256**: Set the preferred curves,
- `SSL_CIPHER_SUITES`: **ecdhe_ecdsa_with_aes_256_gcm_sha384,ecdhe_rsa_with_aes_256_gcm_sha384,ecdhe_ecdsa_with_aes_128_gcm_sha256,ecdhe_rsa_with_aes_128_gcm_sha256,ecdhe_ecdsa_with_chacha20_poly1305,ecdhe_rsa_with_chacha20_poly1305**: Set the preferred cipher suites.
- If there is not hardware support for AES suites by default the cha cha suites will be preferred over the AES suites
- supported suites as of go 1.17 are:
- If there is no hardware support for AES suites, by default the ChaCha suites will be preferred over the AES suites.
- supported suites as of Go 1.18 are:
- TLS 1.0 - 1.2 cipher suites
- "rsa_with_rc4_128_sha"
- "rsa_with_3des_ede_cbc_sha"

2
go.mod

@ -1,6 +1,6 @@
module code.gitea.io/gitea
go 1.17
go 1.18
require (
code.gitea.io/gitea-vet v0.2.2-0.20220122151748-48ebc902541b

Loading…
Cancel
Save